Starting Mineral database

The Mineral database can be accessed by clicking on the button on the GEO main toolbar on the left side of the screen. After clicking the Mineral Browser main window opens (see Mineral Browser – Viewing Minerals and Assays, Figure 1).

Mineral Browser - Viewing Minerals and Assays

Window Layout

Figure 1 The main components of the mineral browser are Mineral Selector on the left, General Properties in the middle and Assay Data on the right. The toolbar on the right containist a number of tools useful in browsing and analyzing the mineral data.

Toolbar and menus

QuickXY
QuickXY is a utility that allows you to draw an XY-plot of any two of elements in a given mineral. The elements can be any two of the ones available in the periodic table and can be the same. It is possible to switch between the XY and Line plots using the “Graph” menu.

QuickLine
QuickLine is a utility that allows you to draw a Line plot of the mineral’s constituent elements. The utility plots the each assay in the database as a line. It is possible to switch between the XY and Line plots using the “Graph” menu.
Graphs
The “Graphs“ button opens HSC data in a plotting mode. After selecting a number of mineral assays you can transfer the selection directly to the HSC Data for plotting. For further help see the help entries for HSC Data.

Tables
The “Tables“ button opens HSC data in a plotting mode. After selecting a number of mineral assays you can transfer the selection directly to the HSC Data for plotting. For further help see the help entries for HSC Data.

Stats
The “Stats“ button opens HSC data in a statistics mode. After selecting a number of mineral assays you can transfer the selection directly to the HSC Data for statistical analysis. For further help see the help entries for HSC Data.

Box&W
The “Box&W“ button opens HSC data for plotting a Box and Whiskers graph. After selecting a number of mineral assays you can transfer the selection directly to the HSC Data for plotting. For further help see the help entries for HSC Data.

PicBook
The “PicBook” button opens HSC Data for viewing the previously saved plots a selected mineral(s). You can save plots from the above tools into a mineral specific picture book and view them later using the PicBook feature.

Add/edit
The “Add/Edit” button opens a mineral assay editor, which lets you add new assays or modify existing ones.
**Tables on the screen**

**Mineral selector**
The Mineral Selector displays every mineral currently entered in the Minerals table in the database. The selector shows the alphabetical list of the minerals available for use. The text field at the top of the Mineral Selector list lets you find a mineral quickly by typing in the mineral’s name.

**General mineral properties**
The General Properties table in the middle of the window displays the mineral properties of the selected mineral. If you have selected several minerals in the selector the general properties are shown for the topmost mineral in the selection. You can display/hide the General Properties by ticking/unticking respectively and the Show General Properties check box at the bottom of the properties table.

**Assay Data**
The table on the right hand side of the mineral browser displays the assay data for the selected minerals. It displays the assays grouped according to mineral name. Clicking on the table shows scrollbars, which allow you to see entire table.

**Navigating the Mineral Selector**

**Finding by name**
Typing a mineral name in the text box at the top of the Mineral Selector list lets you select an individual mineral quickly. The General Properties and Assay Data tables display the information for the first matching mineral (i.e. the first mineral whose name begins with what you typed in the text field).

NB: Be aware that if you type in a name which is not in the database but whose beginning matches a mineral, then that mineral’s data will be displayed.

**Filter**
You may filter minerals in two different ways described below. Clicking on “Ok” will transfer the Selected Mineral Species to the Mineral Browser and show only those in the mineral Selector list. Clicking on “Close” will discard the filter specification.

**Filtering by chemistry (Figure 2):** You can filter minerals by their elemental composition either by requiring certain elements to be included or excluded in the chemical formula. Click on an element to either include (bluish cyan) or excluded (red) it in the chemical formula. Any element that is gray is not included in the search. You can clear your element specifications by clicking on the “clear” button at the bottom right of the periodic table. In the screen capture below the requirement is that the mineral MUST have Calcium, Copper and Zinc but MUST NOT have Titanium. The matching minerals are listed in the table below the periodic table. All of the other elements are ignored.
Figure 2. Selecting minerals using its chemical composition. In the example we require that the mineral contains Calcium, Copper and Zinc (colour coded blue) and that it does not contain Titanium (colour coded red). The grey elements are ignored in the search.

Filtering by mineral name (Figure 3): You can select a field describing a mineral and enter partial data to select minerals from the database. You may choose how the partial data is to be matched against the data in the database by using the four options given. In the screen capture (Figure 3) the minerals have been chosen using the Mineral name field and matched to have the letters “tile” at the end of the mineral name. The matching minerals are again displayed in the able at the bottom of the window.
Figure 3. Selecting minerals using the property fields. The example will find all minerals ending with the text "tile", e.g. Chrysotile, Rutile etc.

Viewing mineral properties (Figure 4): Select the Mineral Properties tab at the top of the window and click on any of the minerals displayed at the bottom to see the mineral’s general properties.
Figure 4. The properties of the minerals matching the search criteria can be viewed before adding them to the selected Mineral Species List. The properties are displayed in the Table at the middle of the dialog (red and blue columns.)

Adding to/removing from selection (Figure 5): The four arrows (>, >>, < and <<) let you move a mineral or minerals to and from the Selected Mineral Species list on the right hand side of the window. Select one mineral and click on “>” to move it to the list or click on “>>” to move all of the minerals currently displayed in the table at the bottom. The “<” and “<<” work similarly but the selection is made in the Selected Mineral Species list and the selected mineral(s) are removed from the list of selected species.
Figure 5. Minerals can be added and removed from the Selected Mineral Species list using the arrow buttons between the list and the properties table in the middle. Single arrow adds/removes the selected mineral species while double arrows add/remove all of the mineral species.

Reset
The Reset button at the bottom of the Mineral Selector on the Mineral Browser window will remove any defined filter (see above) and re-display all of the minerals currently in the database.

Display options

General properties
The “Show General Properties table” button displays and hides the general properties table between the mineral selector list and the assay data table. You can have more space for displaying the assays by hiding temporarily the general properties table.
Clicking this button at the bottom of the assay data table cycles through three different display formats. The formats are Element, which show the assay as weight percentages per each composite element, Oxide, which shows the assay data as oxides and Mixed, which combines the Element and Oxide formats.

Adding and editing mineral assays – Add/edit

Window Layout (Figure 6)

![Figure 6 The mineral add/edit dialog showing a single assay of Alkali feldspar. The properties of the mineral are displayed in the table with one property per line.]

Toolbar and Menus

Edit menu
- **Copy**: Copy the elected fields into the clipboard for pasting somewhere else later.
- **Paste**: Paste the previously copied fields into the current (possibly empty) assay.
- **Paste special assays**: Begins pasting one or more assays copied to the clipboard for another applications such as Excel.
- **Bring Next From Clipboard**: pastes the next assay from the clipboard if any exist. This option is active only if
Convert: Allows you to input the assayed composition as oxides, sulphides or similar. Enter a formula and the amount as ELEMENT UNIT AMOUNT sequence (Figure 7). If the unit is a percentage it can be omitted as show in the screen capture above (Figure 7).

Figure 7. Figure 8 Conversion tool showing how to add Zinc as an oxide. The elemental weight-% of Zinc and Oxygen are automatically calculated.

Tools menu
Move first/Move last: Move to the first or last mineral assay in the editing window respectively.
Delete record: Deletes the currently displayed assay from the database.
Check
check options: Provides a list of checks that can be run against the current assay, the assay loaded in the editor or against the entire database.
check and repair…: Runs the checks specified using Tools->Check->Check Options and performs certain corrections. The scope is similar to the “Check” button.
Calculate
missing oxygen…: If the amount of oxygen has not been given for the mineral, this option calculates the value oxygen..
missing sulphur…: If the amount of sulphur has not been given for the mineral, this option calculates the value based on the assumption that all elements are bonded with sulphur.
Sum=100%…: Calculate the remaining element amounts so that the sum of the weight percentages equals 100.
Filter…: Create a temporary filter to single out one mineral species amongst the minerals loaded into the editor.
No filter…: Remove the temporary filter created using the Filter command above.

Toolbar
Hide empty rows: Clicking the button hides the empty rows in the table. However, in all cases the elements that occur in the mineral’s chemical formula are always displayed. This helps to ensure that all elements are assayed for the minerals and to spot the ones that are not.
Clear: Clicking the **button clears the table in preparation for entering a new assay from scratch.**

Check: Clicking the **button runs the checks specified using the “Tools->Check-Check Option menu for the current mineral assay.**

Find best match: Clicking the **button runs the best match algorithm to identify the mineral in the database that most closely matches the assay currently displayed in the editing window.**

Reference Lookup: Clicking the **button displays the reference lookup dialog to assist in selecting the proper reference for the data in the window. See chapter reference Lookup for more details.**

**Navigating Mineral Editor**

You can move forward and backward among the minerals loaded into the Mineral editor by using the > and < buttons at the bottom left corner of the editor window respectively. The **Move first** and **Move last** commands in the Tools menu let you quickly jump to the beginning or the end of the minerals in the editor.

Filter/No Filter: The Filters command in the Tools menu let you choose all of the assays for a single mineral. Type the mineral’s name in the text field and click on “Ok”. The editor will now let you move among the assays for that particular mineral even if several mineral species were selected for editing. Issuing the **No filter**... command clears the filter and lets you see the original selection of minerals loaded in the editor.

**Adding a new assay**

To add start adding new assays follow either of the procedures described here:

Starting from scratch:

1. Open the add/edit dialog using any mineral
2. Click **clear** to remove the data
3. Type in the mineral’s name and mineral symbol (you may omit either but not both. When you click the **Check** button the system will attempt to fill in the missing field if the mineral exists in the mineral database)
4. Highlight each appropriate field using the arrow keys or the mouse and type in the information.
5. After filling each field click on another field (or use the arrow keys or enter) to accept the new data in the field
6. Input the element weight percentages either directly or by using the F5 (Convert) command
7. When you are done click on the **Save new** button to store the new assay in the database
8. Repeat steps 2-7 as many times as necessary to input the assays

Starting from an existing assay:

1. Open the mineral add/edit dialog by locating and selecting an appropriate previously entered mineral assay and clicking on the Add/edit button to open the dialog.
2. Change the necessary fields (and clear any unnecessary ones) as described in steps 4-8 above

**Editing existing assay**

1. Locate and select the mineral species in question and click Add/edit button to open the editor dialog
2. Change the fields as needed
3. Click on **Save** button to update the assay in the database. NB: This will overwrite the previously entered data in the database. If you decide to add the new data as a new assay clear the MineralID field and click on **Save New**.

**Reference Lookup**

Click on the **reference** button (open book symbol) to open the mineral data reference display (Figure 9). You will be presented with a searchable catalog of every reference entered into the HSCs references table. You can narrow down the list using the text fields at the bottom of the window using the following syntax:

- A string of characters and digits matches the equivalent string in the target column (e.g. Dana, Jones 1990 etc.)
- ? matches any single character
- # matches any single digit 0-9
- * matches an arbitrary string of characters and digits, eg.

Examples:

<table>
<thead>
<tr>
<th>Template</th>
<th>Example matches</th>
</tr>
</thead>
<tbody>
<tr>
<td>Dana</td>
<td>Dana</td>
</tr>
<tr>
<td>Da*</td>
<td>Dana, Data, Dale Datrowski, Dalkey 1922 etc</td>
</tr>
<tr>
<td>19#2</td>
<td>1902, 1912,…1982,1992</td>
</tr>
<tr>
<td>Jacks?n</td>
<td>Jackson, Jacksen etc.</td>
</tr>
</tbody>
</table>

Click on the **Search** button to apply the templates.
You can refine the result step-by-step by entering one set of templates and clicking Search and then entering a different set to narrow the list even further.
To reset the view to display all references click **Show All**.
The screen capture shows an example of using the search criteria to find all references from the years 1960-1969 in any journal starting with “Eco”. 
Figure 9. Reference lookup list showing a sample query to match references in the 1960’s published in anything beginning with “Eco”.

**Pasting assays from clipboard**

The data can be created using Excel provided you adhere to the following format:
The first line or column must be the field names and must include at least the field called Minname. The other fields must exist in the <MineralChemistry table in the database. The easiest way is to follow the procedure below:

1. Open the Editor window using any mineral
2. Select the field names you want to use to input data (note that you may have to copy several unnecessary fields since the selection must be contiguous. DO NOT copy the MineralID field as this is automatically filled by HSC)
3. You may now close the editor window and HSC if you wish. If Windows asks if you want to save the contents of the clipboard click, answer yes.
4. Open Excel and Paste the fields into an empty worksheet
5. Remove the lines which describe the fields you do not need (select the lines by clicking on the line number and using Edit->Delete or Delete from the right-click menu. See Excel’s help for more details on editing the worksheet)
6. Delete the lines with “INPUTTED BY”, “DATE OF DATA INPUT” and “HSID_MINCHEM” (These will be among the last lines in the column)
7. Select the remaining lines and copy them to the clipboard
8. Paste the fields from the clipboard back to an empty worksheet using Edit->Paste Special or “Paste Special from the right-click menu and tick the “Transpose” box in the bottom section of the dialog that pops up
9. If necessary, edit the Excel sheet so that the now horizontal field names are conveniently placed and that the worksheet is clear of any unnecessary data
10. Fill in the data for each field and for each assay you want to enter into HSC. Note that you can save the worksheet and continue entering the data later. Save the worksheet normally and when you come back to the process of entering the data just open the worksheet and continue where you left off.
11. Select the data including the row with the field names and copy the selection to the clipboard using Edit->Copy or Copy from the right-click menu
12. Return to HSC and the editor window.
13. Clear the editor window by clicking on the Clear button
14. Select Edit->paste Special Assays to start pasting the data form the clipboard
15. Check and save the assay using the Check button and then Save New button
16. After the first one continue pasting the data using the Edit->Bring Next From Clipboard
17. Repeat steps 14-15 until all of the data has been entered

Note: An alternate way is to keep the field names vertical in Excel and insert the assay data in columns. This may be better in the case there are few assays but they have several fields that must be entered. The vertical format gives you more visible fields on the screen at one time. Using the horizontal format described above is more natural to read as it resembles ordinary tabulated data.

**Closing the editor window**

You can close the editor dialog by clicking on the close button at the bottom on the dialog or on the red cross at the top right hand corner. Note that if you have not saved the currently displayed mineral your changes will be lost.

**QuickXY**

*Window Layout*

*Figure 10 QuickXY plot of Aegirine assays in the database. The plot is Na against Fe weight-%.*
Toolbar and Menus

Changing what is plotted
You can change which adapt is plotted using the two selection boxes under the graph area. They are labeled X and Y. Open the selection box by clicking on the small arrow to select an element with the mouse or type the element abbreviation (e.g. Ca, Na, U etc) into the text area and press the downward arrow key on the keyboard.

Viewing assay details
Double click on a data point in the XY-view to open the assay details in a table next to the graph (Figure 11).

Changing the graph type
If you want to switch between XY and Line plots of the data, use XY and Line Chart commands in the graph menu.

Saving the plot definition
If you wish to save the element pair you have selected for the axis so that the same elements are plotted against each other for the mineral in the future, select the Save from the File menu. Next time you open the quickXY for the mineral the defined elements are automatically plotted.
QuickLine

Window Layout
The QuickLine window (Figure 12) is very similar to the QuickXY window. The difference is, that QuickLine displays the elemental composition of each assay as a set of lines representing the weight-% of each element in a assay. This gives a good overview of the distribution of the elements in the set of assay for a mineral. In the sample below, 3 assays of aegirine have been plotted. Note that in some cases (e.g. Si) the assay results overlay and thus only 2 lines are visible. The third is hidden under another assay value. Also, there is one assay with non-zero values for P, K, Mn, Mg, Ca and O. Also one assay had non-zero H.

![A Line plot of the Aegirine assays. Note each analyzed value for the elements found are plotted as a line in the corresponding column. Note that some lines overlap and others are nearly hidden at the bottom.](image)

Figure 12

Toolbar and Menus
The menus and toolbar are identical to the QuickXY.

PicBook

Window Layout
The PicBook controls are on the right hand side of the window on the tab titled “Picture book” (Figure 13). You can add a diagram to the picture book by pressing the button.
Figure 13. HSC Data.

Toolbar and Menus

File
- **Open:** Opens a picture book from the disk.
- **Save:** saves that changes to the current picture book.
- **Save as:** saves the current picture book under a (possibly) new name
- **New and clear:** creates a new picture book and clear all data in it.
- **Show picture book file:** displays the picture book file contents as a excel worksheet
- **Close:** closes the picture book viewer

Edit
- **Copy figure text:** Copies the figure title to the clipboard
- **Delete:** Deletes the selected picture from the picture book
- **Rename:** renames the selected picture in the picture book

Animation
- **Run:** Displays the diagrams in the picture book as a sequential animation.
- **Options:** Set the time between changes in the animated diagram sequence
- **run report**
Hide: Clicking on hide closes the picbook panel.

Use filter given in Fig: Uses the filter given.
Use sorter given in Fig: Uses the filter given.
Add objects only: Adds only the annotations (such as lines, text) to the current diagram.

Show caption text
Classify button
Draw button

Adding pictures to the PicBook

You can add diagrams to the picture book by clicking on the button on the toolbar in HSC data diagramming feature. If the mineral doesn’t have a picture book yet, it will be created. NB: When you close HSC Data the application will ask you to save the picture book only on the first time. You can name the picture book file anything you like, but we strongly suggest using the mineral name so that later you can automatically open the picture book from the Mineral database browser by clicking on the PicBook button.

If you add, modify or remove diagrams from an existing picture book you must remember to save the changes using File->save. If you do not save the changes they will be lost when HSC data closes.